[Bug 1777] Accessing _Thread_Dispatch_disable_level should be consolidated

bugzilla-daemon at rtems.org bugzilla-daemon at rtems.org
Fri Apr 15 11:22:45 UTC 2011


--- Comment #3 from Gedare <giddyup44 at yahoo.com> 2011-04-15 06:22:44 CDT ---
(In reply to comment #2)
> I propose the following names:
>   _Thread_Get_dispatch_disable_level(), 
>   _Thread_Set_dispatch_disable_level(), 
>   _Thread_Increment_dispatch_disable_level() and
>   _Thread_Decrement_dispatch_disable_level().
The previous name better keeps the related functionality "close" in name. I
have a feeling this variable will wind up not in the Thread manager eventually,
since it is a core-wide variable that has little to do with threads.

> Otherwise it looks all right.  I don't think that existing assembler code will
> need a change.  This assembler code was written for single core machines.
Good point.

Configure bugmail: https://www.rtems.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the bugs mailing list