[Bug 1787] Adding nesting support to smp spinlock

bugzilla-daemon at rtems.org bugzilla-daemon at rtems.org
Thu May 5 19:02:55 UTC 2011


Gedare <giddyup44 at yahoo.com> changed:

           What    |Removed                     |Added
                 CC|                            |giddyup44 at yahoo.com

--- Comment #1 from Gedare <giddyup44 at yahoo.com> 2011-05-05 14:02:55 CDT ---
The use of multiple layers for naming is not usual. I ran into this before when
refactoring Priority handling and Scheduling. I ultimately chose to use
Package_subpackage_Method as the naming mechanism, e.g.
Scheduler_priority_Schedule(). I would suggest a similar approach to
SMP_lock, with SMP_lock_simple and SMP_lock_nested.

The naming is also confusing for example with SMP_lock_Simple_Control and
SMP_lock_Simple_Spinlock_Obtain; is the package SMP_lock_Simple, or
SMP_lock_Simple_Spinlock?  In the latter, I would suggest
SMP_lock_simple_spinlock or, IMO better would be SMP_lock_spinlock_simple.

The same applies to the Nested (nested) version.

Configure bugmail: https://www.rtems.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the bugs mailing list