[RTEMS Project] #3868: newlib links breaks mingw build

RTEMS trac trac at rtems.org
Mon Feb 10 00:47:07 UTC 2020

#3868: newlib links breaks mingw build
  Reporter:  Chris Johns  |      Owner:  (none)
      Type:  defect       |     Status:  new
  Priority:  high         |  Milestone:  5.1
 Component:  tool/rsb     |    Version:  5
  Severity:  blocker      |   Keywords:
Blocked By:               |   Blocking:
 The following patch in newlib adds links and Windows does not have
 symlinks and it is emulated as copy. This complicates a bsdtar extraction
 of source ...


 I tried the `-E` option that was added to the RSB to extract the tar file
 a second time, this has worked with other tar files with symlinks however
 it does not work. I have no investigated why.

 We need Windows building to make a release.

 **Note, this is in the `tools/rsb` component however is not an RSB bug. I
 need input on what the RSB needs to do to fix this issue if that is the
 path we take.**

Ticket URL: <http://devel.rtems.org/ticket/3868>
RTEMS Project <http://www.rtems.org/>
RTEMS Project

More information about the bugs mailing list