RTEMS | Draft: cpukit: add support for common CAN/CAN FD stack (!49)
Pavel Pisa (@ppisa)
gitlab at rtems.org
Fri Jun 28 10:31:09 UTC 2024
Pavel Pisa commented on a discussion on cpukit/dev/can/ctucanfd/ctucanfd.c: https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/49#note_108439
> +#include <rtems/score/basedefs.h>
> +
> +#include <dev/can/can-devcommon.h>
> +#include <dev/can/can-helpers.h>
> +#include <dev/can/can.h>
> +
> +#include <dev/can/ctucanfd.h>
> +#include "ctucanfd_kframe.h"
> +#include "ctucanfd_kregs.h"
> +#include "ctucanfd_txb.h"
> +#include "ctucanfd_priv.h"
> +
> +#define CTUCANFD_DEBUG 1
> +
> +#define CTUCANFD_IF_MASK 0xFFFF
> +#define CTUCANFD_ID 0xCAFD
This is magic number synthesized to the core. See 3.1.1 DEVICE_ID register description in [CTU CAN FD Core Datasheet Documentation](http://canbus.pages.fel.cvut.cz/ctucanfd_ip_core/doc/Datasheet.pdf). It is local to the CTU CAN FD driver but as it is a value not a mask, it is not part of generated documentation and header files.
--
View it on GitLab: https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/49#note_108439
You're receiving this email because of your account on gitlab.rtems.org.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/bugs/attachments/20240628/91aaf28f/attachment.htm>
More information about the bugs
mailing list