RTEMS | bsp/arm/tms570: Remove misnamed/stale alias TMS570_MMR_SELECT_GMII_SEL (!1271)

Pavel Pisa (@ppisa) gitlab at rtems.org
Wed Jul 22 07:48:42 UTC 2026




Pavel Pisa commented: https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/1271#note_155068


The problem and match of `TMS570_MMR_SELECT_GMII_SEL` should be corrected in RTEMS and LwIP together.

See discussion in https://gitlab.rtems.org/rtems/pkg/rtems-lwip/-/merge_requests/48

The original `TMS570_MMR_SELECT_GMII_SEL` has been replaced by `TMS570_MMR_SELECT_MII_MODE` in the commit

https://gitlab.rtems.org/rtems/rtos/rtems/-/commit/3a0dcd5ee97dd150cdea9d1d2ca06e81f58436fc

So this should be the variant provided and used. But LwIP needs to be adjusted as well.

As for the default pin initialization list, it seems that there should be introduced BSP build option or some other mechanism to choose between HDK and Lauchpad, because I expect that they differ in MII pins/balls allocation.

@ar-in0 has Lauchpad TMS570LC4357, I have TMS570LC3137 and TMS570LC4357 HDKs so we should try to test that on all of them as time allows.

-- 
View it on GitLab: https://gitlab.rtems.org/rtems/rtos/rtems/-/merge_requests/1271#note_155068
You're receiving this email because of your account on gitlab.rtems.org. Unsubscribe from this thread: https://gitlab.rtems.org/-/sent_notifications/4-ci1jak794x85bqo0n5tqh35kr-1d/unsubscribe | Manage all notifications: https://gitlab.rtems.org/-/profile/notifications | Help: https://gitlab.rtems.org/help


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/bugs/attachments/20260722/15238f15/attachment.htm>


More information about the bugs mailing list