Yum Repo Broken for F15?

Ralf Corsepius ralf.corsepius at rtems.org
Wed Dec 14 14:13:19 UTC 2011

On 12/14/2011 03:02 PM, Joel Sherrill wrote:
> On 12/14/2011 02:25 AM, Chris Johns wrote:
>> On 14/12/11 1:44 PM, Ralf Corsepius wrote:
>>> BTW: Was this from inside OAR's network?
>>> Several of my gdb-build jobs have died with bizarre build errors, I 
>>> have
>>> no real explanation for. Some of them look like effects of a networking
>>> issues other like dying HW. An explanation bor both would be a
>>> man-in-the-middle attack or a misconfigured router/machine on OAR's
>>> network (e.g. duplicate IP addresses)
>> Is this over nfs ?
> There was absolutely nothing wrong with OAR's network at the
> time, 
Network timeouts speak a different language, but ... yes, there is no 
proof for claim.

Rest assured, next time such incident happens, I am going to post the 
build log to this list.

> it installed cleanly using rpm when I mounted the ftp site via NFS.
> It turns out to be a confused yum cache after trying to upgrade.
> My /boot partition is apparently too small to upgrade and I will
> have to resize partitions.  The "preupgrade" contents were laying
> around.
> So far my luck with preupgrade is 0 for 2 on the two machines I
> have tried this week. :(
Well, official Fedora recommendation: 500MB boot at least. Last time I 
tried (> 1/2 year ago, during an 14->15 test upgrade) it this wasn't 
sufficient, however the amount need varies in wide ranges, depending 
upon the number and the size of installed packages (i.e. the size can be 
trimmed down by deinstalling packages in advance to upgrading).

In general, I am not using preupgrade, but I am using "yum on the fly 
upgrades" or "DVD upgrades".
yum-on-the-fly is not suitable for everbody, but works sufficiently for me.


More information about the devel mailing list