[PATCH] Add and use kputc()
Sebastian Huber
sebastian.huber at embedded-brains.de
Mon Aug 13 14:57:00 UTC 2012
On 08/13/2012 04:18 PM, Gedare Bloom wrote:
> I have no issue with this change but it does "pollute" the public namespace.
Yes, everyone using printk() has to deal now also with kputc(). This is not
good. What about rtems_console_putc()? Maybe we should rename some of the
other functions, e.g.
int rtems_console_getc(void);
static inline int getchark(void)
{
return rtems_console_getc();
}
void rtems_console_puts(const char *s);
static inline void putk(const char *s)
{
rtems_console_puts(s);
}
--
Sebastian Huber, embedded brains GmbH
Address : Obere Lagerstr. 30, D-82178 Puchheim, Germany
Phone : +49 89 18 90 80 79-6
Fax : +49 89 18 90 80 79-9
E-Mail : sebastian.huber at embedded-brains.de
PGP : Public key available on request.
Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
More information about the devel
mailing list