[PATCH 8/9] score: Add _Objects_Release_for_get_isr_disable()
Sebastian Huber
sebastian.huber at embedded-brains.de
Thu Jun 6 13:54:58 UTC 2013
On 06/06/2013 03:41 PM, Gedare Bloom wrote:
> I don't understand the name of the function. What do you intend to say
> with "Release_for_get_isr_disable"?
There are basically two functions to get an object by its identifier:
_Objects_Get()
_Objects_Get_isr_disable()
For _Objects_Get() we have _Objects_Release() (or _Objects_Put()) or
_Objects_Release_without_thread_dispatch().
For _Objects_Get_isr_disable() I introduced
_Objects_Release_for_get_isr_disable() since these functions must be used
pairwise. This _Objects_Get_isr_disable() is an optimization for semaphores
which doesn't work on SMP.
I am not happy with the name, but couldn't find a better one.
--
Sebastian Huber, embedded brains GmbH
Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone : +49 89 189 47 41-16
Fax : +49 89 189 47 41-09
E-Mail : sebastian.huber at embedded-brains.de
PGP : Public key available on request.
Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
More information about the devel
mailing list