[PATCH] score: Add CPU counter support
sebastian.huber at embedded-brains.de
Wed Feb 12 13:40:21 UTC 2014
On 2014-02-12 09:43, Sebastian Huber wrote:
>> I'm not quite sure about the _CPU_ interfaces naming convention. I
>> thought in the score the CPU is the "package" and we logically
>> associate 'subpackages' and their methods, like _CPU_Context_xxx(),
>> _CPU_Exception_xxx(), etc. However, I see at least _CPU_atomic_Xxx()
>> violates this, so I don't know what the right way should be by looking
>> at the code.
> Ok, if we use the rule _Package_name_Sub_package_name_Function_name, then we
> should use
> We should also adjust the CPU atomic API.
Maybe we should drop the sub-packages. This would lead to
_CPU_Counter_Read() -> _CPU_Counter_read()
_CPU_Atomic_Compare_exchange_ptr() -> _CPU_Atomic_compare_exchange_ptr()
_CPU_SMP_Get_current_processor() -> _CPU_SMP_get_current_processor
Sebastian Huber, embedded brains GmbH
Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone : +49 89 189 47 41-16
Fax : +49 89 189 47 41-09
E-Mail : sebastian.huber at embedded-brains.de
PGP : Public key available on request.
Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
More information about the devel