waf and Python 3.7

Christian Mauderer list at c-mauderer.de
Wed Dec 19 10:36:03 UTC 2018

Am 19.12.18 um 10:46 schrieb Chris Johns:
> On 19/12/18 8:20 pm, Christian Mauderer wrote:
>> I think you are discussing some other bug(s) than the one I originally
>> meant. 
> Yes we are discussing something else that is wrong with the docs builds. Sorry
> about hijacking the thread.

No problem. I was just worried that you might want to put work into
fixing something that isn't the problem. Of course it sounds like it
_is_ a bug but it is not the one that I meant.

>> First of all: I tried a pdf build. But I receive the same error
>> on a html build.
> I do not see this error.
>> See attached log for the complete output with python2
>> on the current HEAD (75f24638b3f).
> I cannot see what is wrong. There is a waf configure option to add verbose
> levels to `sphinx-build`. I suggest you add '-v -v' to see if it can provide
> some insight to the problem.
> The waf script glob's the directory. Is there something in your tree which is
> getting picked up?

For some odd reason, the sphinx on my system expects a contents.rst
instead of a index.rst. Is seems like the master_doc in common/conf.py
is somehow ignored. If I do the following before the build, everything
works fine:

for f in **/index.rst; do ln -s index.rst "`echo $f | sed
's/index.rst/contents.rst/'`"; done

My sphinx version is 1.8.1.

>> What I meant is a simple indentation error in common/waf.py. Python 3
>> seems to be a little picky about these. It throws a "TabError:
>> inconsistent use of tabs and spaces in indentation". I'll post a patch
>> for review in a few minutes.
> I understood this and thanks for the patch. Please push it.


>> Regarding the ticket: I updated the title and added a comment to reflect
>> the fact that multiple repos are affected.
> Thanks.
>> I'll update the waf in libbsd soon. I haven't tested examples-v2 yet so
>> this will need some more time. And I won't update rtems-docs till I'm
>> able to build it. I'll also post a patch for review that will update the
>> rtems-tools in RSB to use the new version.
> Thanks

Libbsd is updated. For some reason the ticket in Track hasn't picked up
the change. Did I make some error in the description?


> Chris

Best regards,


More information about the devel mailing list