GSoC Project | Basic Support for Trace Compass

Ravindra Kumar Meena rmeena840 at gmail.com
Fri Aug 9 17:32:42 UTC 2019


>
>
> Ok, good. Please always check if the babeltrace and Trace Compass give
> the right results after the changes.
>
Yes. Both are displaying same output.

>
> If you use cctx->switch_event[ item->cpu ] and similar a couple of times
> in a function, then please assign it to a local pointer and use it, e.g.
>
> switch_event *se = &cctx->switch_event[ item->cpu ];
>
> Please check all structure names and make the similar to the names used
> in the metadata, e.g. swich_event -> event_sched_switch;
>
> Please check the style of the if again, it should be:
>
> if ( condition ) {
>   ...
> } else {
>   ...
> }
>
> Check the white space and position of the { }.
>
> When you have a function like get_api_of_id() you return the api, so the
> variable should be named "api":
>
>    size_t api_id = get_api_of_id( cctx->thread_id_name[ item->cpu
> ].thread_id );
>
>    size_t api = get_api_of_id( cctx->thread_id_name[ item->cpu
> ].thread_id );
>
> Declare all variables at the top of the function, e.g.
>
> size_t api;
> ...
> api = get_api_of_id( cctx->thread_id_name[ item->cpu ].thread_id );

https://github.com/rmeena840/rtems-tools/commit/11cf7626e40a20c9bfaf889a94d51171519d6dc0



-- 
*Ravindra Kumar Meena*,
B. Tech. Computer Science and Engineering,
Indian Institute of Technology (Indian School of Mines)
<https://www.iitism.ac.in/>, Dhanbad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/devel/attachments/20190809/6513f3dc/attachment-0002.html>


More information about the devel mailing list