[GSoC 2020]: Doubts related to testing for EPICS7+RTEMS5 (pc386) built using recipe.

Mritunjay Sharma mritunjaysharma394 at gmail.com
Wed Jul 29 23:11:50 UTC 2020

Hello all!

I tried to work on the testing part and here's what I did as per my

I went inside the epics built by RSB recipe and ran "make runtests".
It gave results somewhat like this:

"Base.t ........ ok
Breaktable.t .. ok
DBD.t ......... ok
Device.t ...... ok
Driver.t ...... ok
Function.t .... ok
Menu.t ........ ok
Recfield.t .... ok
Recordtype.t .. ok
Registrar.t ... ok
Variable.t .... ok
All tests successful.
Files=11, Tests=293,  1 wallclock secs ( 0.05 usr  0.00 sys +  0.40 cusr
 0.06 csys =  0.51 CPU)
Result: PASS"

I also downloaded rtems-testing directory and tried to run simulator
using the tutorial here:

However, I was encountered with this error when I entered:
```./sim-scripts/pc386 -i

Error: ```qemu-system-i386: Initialization of device ide-hd failed: Block
node is read-only```.

It is very much possible that I am following a wrong approach for testing.
I really look forward to you all to help me out with it and
also share some resources which can help me guide on what exactly I have
to proceed with ahead.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/devel/attachments/20200730/8b1aa4f3/attachment.html>

More information about the devel mailing list