[GSoC 2020]: Doubts related to testing for EPICS7+RTEMS5 (pc386) built using recipe.

Heinz Junkes junkes at fhi-berlin.mpg.de
Thu Jul 30 01:29:44 UTC 2020

I will be back online next weekend. Just a short note:
Mritunjay, please have a look on github epics-base in the directory ci-scripts 
Here you should find automated tests etc. used by the epics development team.


> On 30.07.2020, at 01:33, Chris Johns <chrisj at rtems.org> wrote:
>> On 30/7/20 9:11 am, Mritunjay Sharma wrote:
>> Hello all!
>> I tried to work on the testing part and here's what I did as per my understanding:
>> I went inside the epics built by RSB recipe and ran "make runtests". 
>> It gave results somewhat like this: 
>> "Base.t ........ ok      
>> Breaktable.t .. ok  
>> DBD.t ......... ok    
>> Device.t ...... ok    
>> Driver.t ...... ok  
>> Function.t .... ok  
>> Menu.t ........ ok    
>> Recfield.t .... ok    
>> Recordtype.t .. ok    
>> Registrar.t ... ok  
>> Variable.t .... ok  
>> All tests successful.
>> Files=11, Tests=293,  1 wallclock secs ( 0.05 usr  0.00 sys +  0.40 cusr  0.06
>> csys =  0.51 CPU)
>> Result: PASS"
> What is EPICS running to test the executables? Do they expect a suitable QEMU in
> the $PATH? In other words what are the dependencies EPICS required to run these
> tests?
>> I also downloaded rtems-testing directory
> Could you please explain what this means? For me this could mean many things and
> I suspect they are not the same as you. Please be provide the needed detail for
> me or anyone to understand this statement, that is the URL, git command or
> whatever that makes sense. For example there is the personal repo of Joel's,
> something EPICS has, the rtems-test command, or you may have found a tar file
> somewhere.
> Please provide the command line you entered and if there is an error the
> relevant pieces of the output.
>> and tried to run simulator
>> using the tutorial here: https://devel.rtems.org/wiki/Developer/Simulators/QEMU
> This page was updated over 2 years ago and as is the problem with wiki, the
> pages can age. I have added a suitable warning to that page. My advice is to
> consult the User Manual before the wiki.
>> However, I was encountered with this error when I entered: 
>> ```./sim-scripts/pc386 -i
>> ~/development/rtems/kernels-5/pc-386/i386-rtems5/c/pc386/testsuites/samples/hello.exe```
>> Error: ```qemu-system-i386: Initialization of device ide-hd failed: Block node
>> is read-only```.
> The User manual has a section titled "Testing". I suggest you refer to that.
>> It is very much possible that I am following a wrong approach for testing. 
>> I really look forward to you all to help me out with it and
>> also share some resources which can help me guide on what exactly I have 
>> to proceed with ahead. 
> I hope this help. Please let me know how you go.
> Chris

More information about the devel mailing list