RTEMS Documentation build problem

Jeff Mayes Jeff.Mayes at OARcorp.com
Thu May 20 16:28:03 UTC 2021

Hi all,

I'm trying to build the RTEMS Documentation, but having a problem with sphinxcontrib-bibtex.  It's been a long time since I've tried this, so maybe there's a configuration problem on my end.  Anyway, I've pulled down the rtems-docs repo and tried to follow the instructions in the README.  Installation of all the tools seems good, but running waf configure fails.

Thanks in advance for any advice.

$ ./waf configure -v --pdf --singlehtml --prefix=/home/mayes/Documents/rtems
Checking for 'sphinxcontrib.bibtex'      : 11:18:46 runner ' /home/mayes/sphinx/bin/sphinx-build -b html -D extensions=sphinxcontrib.bibtex -c . . out '
not found (see README.txt)
The configuration failed
(complete log in /home/mayes/rtems-docs/build/config.log)

Here's the relevant output from the build/config.log file:

Checking for 'sphinxcontrib.bibtex'
[1/1] Processing ^[[01;34mbuild/.conf_check_4f991dacd3d42895f236eb1da8e20c9e/testbuild/contents.rst^[[0m

/home/mayes/sphinx/bin/sphinx-build -b html -D extensions=sphinxcontrib.bibtex -c . . out
out: Running Sphinx v4.0.2
making output directory... done
building [mo]: targets for 0 po files that are out of date
building [html]: targets for 1 source files that are out of date
updating environment: [new config] 1 added, 0 changed, 0 removed
reading sources... [100%] contents

err: WARNING: could not open bibtex file /home/mayes/rtems-docs/build/.conf_check_4f991dacd3d42895f236eb1da8e20c9e/testbuild/refs.bib.
WARNING: Since v2.0, Sphinx uses "index" as root_doc by default. Please add "root_doc = 'contents'" to your conf.py.

Extension error (sphinxcontrib.bibtex.domain):
Handler <function env_updated at 0x7fc4db8e6a60> for event 'env-updated' threw an exception (exception: 'index')

from /home/mayes/rtems-docs/user: Test does not build: Traceback (most recent call last):
  File "/home/mayes/rtems-docs/.waf3-2.0.19-1f3c580272b15a03d2566843c5fe872a/waflib/Configure.py", line 333, in run_build
  File "/home/mayes/rtems-docs/.waf3-2.0.19-1f3c580272b15a03d2566843c5fe872a/waflib/Tools/errcheck.py", line 140, in check_compile
  File "/home/mayes/rtems-docs/.waf3-2.0.19-1f3c580272b15a03d2566843c5fe872a/waflib/Build.py", line 176, in compile
    raise Errors.BuildError(self.producer.error)
waflib.Errors.BuildError: Build failed
-> task in '' failed with exit status 2:
        {task 140180890500232: ${BIN_SPHINX_BUILD} -b html -D extensions=sphinxcontrib.bibtex -c . . out contents.rst -> }
' /home/mayes/sphinx/bin/sphinx-build -b html -D extensions=sphinxcontrib.bibtex -c . . out '

not found (see README.txt)
from /home/mayes/rtems-docs/user: The configuration failed
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/devel/attachments/20210520/30667da5/attachment-0001.html>

More information about the devel mailing list