#define delay(...)

Sergei Organov osv at javad.ru
Fri Nov 10 14:18:30 UTC 2000


I've found that most of RTEMS 'bsp.h' files define macro 'delay', like this:

#define delay( _microseconds )\

I believe 'delay' is too general to be a name of exported macro because it
likely to create conflicts with usage of the name in user code. In fact it did 
create conflict in my case. Don't you think it's better to rename the macro
(e.g., to 'rtems_delay')?

Sergei Organov.

More information about the users mailing list