RPM question (old linux version)

Gene Smith gds at chartertn.net
Fri Aug 20 02:02:46 UTC 2004

Joel Sherrill <joel at OARcorp.com> wrote, On 
08/19/2004 08:45 PM:
> gene smith wrote:
>> I see that the tool RPMs are in a directory contain rh7.3 in its path, 
>> i.e. ftp.rtems.com/pub/rtems/linux/redhat/7.3/i386/rpms/rtems-4.6/
>> I think this just means that the rpm's were build with verion 7.3. I 
>> have seen they work with fc2 version.
> I wouldn't expect them to install. The RPM version changed.  I remember
> that when we built RPMs on 6.x, they would run on 7.x, but I don't
> remember about the other direction.

The 4.6.1 binutils/gcc/newlib/gdb rpm's definite install and run fine on 
fc2 for me. But could not get them to install on old rh 6.1 due to 
dependency error shown below.

> Ralf would know for sure, but building from the SRPMs would probably
> work even with the older RPM version and would be best.

I did not try the SRPM route on rh 6.1 since I figured it would have the 
same depedency problem. However, build from source seems to to working 
on the rh 6.1 which I left running at work before I came home. (The 
build of gcc/newlib seems to take forever!)

>> However, can I expect them to work
>> with a really old version, e.g., rh 6.1? When I try to install I get a 
>> dependency error:
>> [root at 96J076 archive]# rpm -iv 
>> rtems-4.6-rtems-base-gcc-gcc3.2.3newlib1.11.0-4.i386.rpm
>> error: failed dependencies:
>>         rpmlib(PayloadFilesHavePrefix) <= 4.0-1 is needed by 
>> rtems-4.6-rtems-base-gcc-gcc3.2.3newlib1.11.0-4
>>         rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by 
>> rtems-4.6-rtems-base-gcc-gcc3.2.3newlib1.11.0-4
>> -gene

More information about the users mailing list