new baby in the multilib family

Tim timcussins at
Tue Jul 15 16:35:55 UTC 2008

On Mon, 2008-07-07 at 14:32 -0700, Till Straumann wrote:
> I just realized that a new baby (8540) recently has joined the already big
> powerpc multilib family (IMO w/o good reason).

> b) have somebody explain why they think mcpu=XYZ other than mcpu=powerpc 
> is necessary
>     If no good reason is found after discussion, kill the unnecessary ones.

+1 for trimming ppc multilibs.

I'm working on ppc440 support - it looks like setting mcpu=powerpc
(inside make/custom/my_bsp.cfg) might prevent the use of a whole bunch
of extended mnemonics: those that use mtspr/mfspr for example. It'd be
cool to keep these for readability in dlentry.S (or equiv).



More information about the users mailing list