How to add a compile time configuration option to something in cpukit?
Sebastian Huber
sebastian.huber at embedded-brains.de
Thu Sep 3 10:18:55 UTC 2009
Hi,
the FTP client resides in the cpukit. It can use gethostbyname() to obtain an
internet address from a DNS name. The dependency on DNS adds 35k of code
(THUMB op-codes). I want to add a configuration option to disable this
feature. Can I add this with RTEMS_CPUOPT in cpukit/configure.ac? What are the
naming conventions for such options? I would use
RTEMS_CPUOPT([RTEMS_FTPFS_DISABLE_DNS_SUPPORT],
[test x"${RTEMS_FTPFS_DISABLE_DNS_SUPPORT}" = x"1"],
[1],
[disables DNS support for the FTP client])
Have a nice day!
--
Sebastian Huber, embedded brains GmbH
Address : Obere Lagerstr. 30, D-82178 Puchheim, Germany
Phone : +49 89 18 90 80 79-6
Fax : +49 89 18 90 80 79-9
E-Mail : sebastian.huber at embedded-brains.de
PGP : Public key available on request.
Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
More information about the users
mailing list