PCI drivers - BAR addresses
dnpaterson at gmail.com
Mon Oct 28 14:37:22 UTC 2013
On 28 October 2013 12:17, Daniel Hellstrom <daniel at gaisler.com> wrote:
> Ok, thanks for letting me know.
> You can have a look at the changelog, I think the 220.127.116.11 introduced
> changes in the drvmgr API names, the changelog describe a way to update
> some of the changes:
> sed -e 's/rtems_drvmgr_dev_info/**drvmgr_dev/g' \
> -e 's/rtems_drvmgr_bus_info/**drvmgr_bus/g' \
> -e 's/rtems_drvmgr_drv_info/**drvmgr_drv/g' \
> -e 's/rtems_drvmgr_/drvmgr_/g' -i FILE
> The configuration (for example drvmgr_leon3_config.c) has changed too to
> avoid unnecessary malloc() calls during initialization.
I'm working through these changes at the moment, and making good progress.
I've run into a strange problem in using functions like
"pci_read_config_dword()" however, and I'm getting them as undefined.
I've looked for them in various header files, but can't get any combination
of headers to compile successfully. I did see that there are now functions
in the style of "grpci_cfg_r32()", and wonder if I should be using these
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the users