[Bug 1599] change _Context_Switch_necessary to _Dispatch_needed

bugzilla-daemon at rtems.org bugzilla-daemon at rtems.org
Sun Jul 4 19:18:52 UTC 2010


--- Comment #3 from Gedare <giddyup44 at yahoo.com> 2010-07-04 14:18:50 CDT ---
(In reply to comment #2)
> I don't have a problem changing the name of this variable.  I think it needs to
> reflect that a dispatch is needed but the new name breaks the naming
> convention.  Think of it as package::member where the the first letter of the
> "package" is transformed into _P and the member is transformed into _M.
> So this implies there is a package with a .h named Dispatch and "needed" would
> need to be capitalized.
> So we need to start by identifying the elements in the "Dispatcher" package I
> think.

I had the concern about naming also. As it stands, the dispatch is part of the
Thread package, so it could easily be called _Thread_Dispatch_needed to imply
that Thread_Dispatch should be doing some work.  Otherwise I can add a new
Dispatch Handler to the score, which makes some sense as dispatching on SMP
systems may complicate the normal thread dispatch logic.

Configure bugmail: https://www.rtems.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the bugs mailing list