coverage analysis failed

Krzysztof Mięsowicz krzysztof.miesowicz at
Mon Aug 13 12:45:37 UTC 2012

First I tried to invoke do_coverage with BSP declaring only but I saw that
didn't run tests. Then I invoked do_coverage with -A option which means do
all. I also tried it without updating, configuring and building rtems as it
has been done earlier.

I have just run pc386 with -c option (coverage on) for hello.exe and it
seems to work properly. It generated log and hello.exe.cov file also.

2012/8/13 Joel Sherrill <Joel.Sherrill at>

>  How did you invoke the do_coverage script?
> Which any did it report using?
> Can you run the pc386 script on hello with the coverage option and see what happens?
> If it doesn't work on a simple case that is one thing.
> Krzysztof Mięsowicz <krzysztof.miesowicz at> wrote:
> Hi all,
> I'm Krzysztof and I'm this year ESA SOCIS student. I'm working on RTEMS
> coverage improvement. Actually I'm trying to prepare environment to run
> coverage analysis on my laptop and I have some troubles with it. I had some
> problems with was due to lack of qemu and path to qemu but this is solved.
> I have run do_coverage script. It executed all tests but then I get a lot
> of warnings such as
> "WARNING: Unable to read coverage file unlimited.exe.cov" and error:
> "ERROR: No information to analyze"
> FAILED:  covoar failed
> I'm very confused with it and hope anyone can help me :)
> Regards
> Krzysztof Miesowicz
> krzysiekm13
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the devel mailing list