[PATCH 3/4] rtmes: Add scheduler get processors

Sebastian Huber sebastian.huber at embedded-brains.de
Wed Apr 9 11:49:00 UTC 2014


On 2014-04-09 13:35, Joel Sherrill wrote:
> I do not like the name of this method. It should be something like get default
> cpuset. This name is misleading and too close to something that would return a
> simple number of cores.

What about rtems_scheduler_get_processor_set()?

We should decide if we use "cpu" or "processor" throughout our code base.

Currently we have:

rtems_smp_get_current_processor()
rtems_smp_get_processor_count()
rtems_configuration_get_maximum_processors()

I think we should drop the "smp" and simply use:

rtems_get_current_processor()
rtems_get_processor_count()

-- 
Sebastian Huber, embedded brains GmbH

Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone   : +49 89 189 47 41-16
Fax     : +49 89 189 47 41-09
E-Mail  : sebastian.huber at embedded-brains.de
PGP     : Public key available on request.

Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.



More information about the devel mailing list