[PATCH 3/4] rtmes: Add scheduler get processors

Gedare Bloom gedare at rtems.org
Wed Apr 9 14:54:38 UTC 2014


On Wed, Apr 9, 2014 at 7:49 AM, Sebastian Huber
<sebastian.huber at embedded-brains.de> wrote:
> On 2014-04-09 13:35, Joel Sherrill wrote:
>>
>> I do not like the name of this method. It should be something like get
>> default
>> cpuset. This name is misleading and too close to something that would
>> return a
>> simple number of cores.
>
>
> What about rtems_scheduler_get_processor_set()?
>
> We should decide if we use "cpu" or "processor" throughout our code base.
>
I don't like cpu. it is outdated now because there is no central
processor unit in a chip multiprocessor. I prefer processor as a
generic term.

> Currently we have:
>
> rtems_smp_get_current_processor()
> rtems_smp_get_processor_count()
> rtems_configuration_get_maximum_processors()
>
> I think we should drop the "smp" and simply use:
>
> rtems_get_current_processor()
> rtems_get_processor_count()
>
I'm good with this, especially with the effort to unify the API as
much as possible for SMP and non-SMP. These functions can have
well-defined semantics on non-smp.
-Gedare
> --
> Sebastian Huber, embedded brains GmbH
>
> Address : Dornierstr. 4, D-82178 Puchheim, Germany
> Phone   : +49 89 189 47 41-16
> Fax     : +49 89 189 47 41-09
> E-Mail  : sebastian.huber at embedded-brains.de
> PGP     : Public key available on request.
>
> Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
>
> _______________________________________________
> rtems-devel mailing list
> rtems-devel at rtems.org
> http://www.rtems.org/mailman/listinfo/rtems-devel




More information about the devel mailing list