Problem with ticker.exe for or1ksim/OpenRISC BSP

Hesham Moustafa heshamelmatary at
Thu Jul 17 09:57:56 UTC 2014


I am trying to get ticker.exe working properly for or1ksim BSP but
there is a problem. When I run ticker, I only get the following output

TA1  - rtems_clock_get_tod - 09:00:00   12/31/1988
TA2  - rtems_clock_get_tod - 09:00:00   12/31/1988
TA3  - rtems_clock_get_tod - 09:00:00   12/31/1988"

And nothing else. I tried to debug this issue using the following methods:

1- Set a break point at "put_name( Task_name[ task_index ], FALSE );"
line, it always reach this point (with different task ids each time)
but does not produce any output.

2- Set a break point at _Watchdog_Tickle function, and it's reached
every time and decreasing the interval successfully.

3- Set a break point at _Watchdog_Remove function, and it's always
reached every time I hit continue.

4- Set a break point at "status = rtems_clock_get_tod( &time );" at
ticker.c, and time.second is always 0, never incremented. I though
Clock_driver_nanoseconds_since_last_tick is the problem, so I made it
return a static value to test it (12345 for example), but I got the
same problem.

Please note that the previous break points always reached when I hit
continue every time, the timer interrupt keeps arising and do its work
never stops, and the problem enters IDLE task.

I would appreciate any hints or solutions regarding this problem.


More information about the devel mailing list