[PATCH 1/6] Patches for the OR1k CPU handling and definitions

Gedare Bloom gedare at rtems.org
Sat Feb 20 22:16:47 UTC 2016


On Sat, Feb 20, 2016 at 3:22 PM, Jakob Viketoft
<jakob.viketoft at aacmicrotec.com> wrote:
> Hello Gedare,
> ________________________________________
> From: devel [devel-bounces at rtems.org] on behalf of Gedare Bloom [gedare at rtems.org]
> Sent: Saturday, February 20, 2016 14:23
> To: jakob.viketoft at gmail.com
> Cc: rtems-devel at rtems.org
> Subject: Re: [PATCH 1/6] Patches for the OR1k CPU handling and definitions
>
>>Hi Jakob,
>>
>>I should have mentioned yesterday that you ought to open one or more
>>tickets on our Trac (devel.rtems.org) and then reference those tickets
>>in your commit messages using e.g. "updates #xxxx" or "fixes #nnnn".
>
> Right-oh. Feel like I'll be spamming the list with the same patches all over again, but I'll get to it.
>
>>Also, if your test cases are suitably generic and useful, you might
>>consider providing them as separate contributions to improve RTEMS
>>test suite.
>
> I have considered that, but at the moment at least they're not in a clean enough state to be presentable as such, but we might contribute something later. In essence it's expansions on current tests (notably ticker), but still.
>
>>> diff --git a/cpukit/score/cpu/or1k/rtems/score/cpu.h b/cpukit/score/cpu/or1k/rtems/score/cpu.h
>>> index 7364343..740bdda 100644
>>> --- a/cpukit/score/cpu/or1k/rtems/score/cpu.h
>>> +++ b/cpukit/score/cpu/or1k/rtems/score/cpu.h
>>...
>>> @@ -385,6 +574,17 @@ static inline void _OR1K_Sync_pipeline( void )
>>>  #define _OR1KSIM_CPU_Halt() \
>>>         asm volatile ("l.nop 0xc")
>>>
>>> +static inline uint32_t _OR1K_Find_First_One(uint32_t value)
>>Probably should be using _OR1K_Find_first_one() -- see also
>>https://devel.rtems.org/wiki/Developer/Coding/NamingRules
>
> Ok, I thought we followed the naming used earlier in the file, but looking at the rules, the camelcase shouldn't have passed either. :) If I had done it from scratch, I probably would have preferred an entire lower-case function name, but as it is I thought I'd go along with what's already there (and at least partly reviewed). Does this mean I should adjust some of the other names as well, or just this one?
>
You may adjust the others if they violate the pattern
_Package_Method_name() that is used in the score API. Sometimes things
slip through review.

> Thanks for checking!
>
>>_______________________________________________
>>devel mailing list
>>devel at rtems.org
>>http://lists.rtems.org/mailman/listinfo/devel
>
> Jakob Viketoft
> Senior Engineer in RTL and embedded software
>
> ÅAC Microtec AB
> Dag Hammarskjölds väg 48
> SE-751 83 Uppsala, Sweden
>
> T: +46 702 80 95 97
> http://www.aacmicrotec.com



More information about the devel mailing list