Updates and Problems on "Raspberry Pi USB and Ethernet Support" Project

Alan Cudmore alan.cudmore at gmail.com
Tue Jul 12 13:32:48 UTC 2016

I'm not sure what I did to get the extra debug messages. When I run the
usb01 example, I just see:
nexus0: <RTEMS Nexus device>

I will have to read up on how the libbsd drivers are used, and what needs
to be done to set them up in nexus-devices.h

Chris: do you know if it would help to boot FreeBSD on the Pi to see the
messages and look at what drivers are used?


On Tue, Jul 12, 2016 at 12:41 AM, Deval Shah <deval.maker at gmail.com> wrote:

> I am sorry, I forgot to mention those details.
> I have added --freebsd-options=bootverbose,verbose_sysinit,bus_debug for
> more log, while configuring waf.
> There are two branches currently. RaspberryPi_USB and rpi_usb. Both are
> same as far as my added code is concerned. rpi_usb has a different starting
> point and not updated while the other one is up to date.
> The problem with the RaspberryPi_USB was that due to some other updates in
> mainline, I was not getting the device_printfs. So I switched back to the
> old repo of mine.
> Also, I am surprised how you are getting the device_printfs on my latest
> code. https://lists.rtems.org/pipermail/devel/2016-July/015557.html
> Regards,
> Deval Shah
> On Tue, Jul 12, 2016 at 7:05 AM, Alan Cudmore <alan.cudmore at gmail.com>
> wrote:
>> Hi Deval,
>> What code do I need to add to try your test?
>> I am using the items git head kernel, and your rtems-libbsd
>> RaspberryPi_USB branch.
>> When I run init01 on my Pi Zero, I get the output below.
>> Alan
>> *** LIBBSD INIT 1 TEST ***
>> nexus0: <RTEMS Nexus device>
>> bcm283x_dwcotg0: <DWC OTG 2.0 integrated USB controller (bcm283x)> on
>> nexus0
>> usbus0 on bcm283x_dwcotg0
>> usbus0: 480Mbps High Speed USB v2.0
>> uhub0: <DWCOTG OTG Root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0
>> Sleeping to see what happens
>> uhub0: 1 port with 1 removable, self powered
>> On Jul 11, 2016, at 10:37 AM, Deval Shah <deval.maker at gmail.com> wrote:
>> Hello all,
>> I am trying to add usb_ethernet (smsc) driver for raspberry pi for both
>> USB and Ethernet support.
>> Now I have added the required files. But the USB device is not getting
>> power. To get the compilation error-less, I have applied a hack.
>> if_smsc.c is using the function “usbd_m_copy_in” which is present in the
>> file sys/dev/usb/usb_busdma.c. But due to this macro #if USB_HAVE_MBUF the
>> function was not getting compiled. So I have commented out the macro and
>> let the function compile.
>> Now ideally I should have used the DMA controller. Here I don't know the
>> status of DMA's functions and their usage. Any pointers on that ?
>> I believe the problem is secondary for the USB to function. Anyhow the
>> USB devices should get the power if the code is added. I suspect there is
>> no proper linking between the drivers. (i.e. dwcotg, bcm283x_dwcotg, ushub,
>> smsc, uhub, usb.) I would like some insights on how these interact.
>> I have added following lines in the nexus-devices.h file under
>> Raspberry-pi-BSP.
>> SYSINIT_DRIVER_REFERENCE(bcm283x_dwcotg, nexus);
>> I am also attaching the log of INIT01 Test.
>> I need help at this point. I am kind of stuck here.
>> Thank you in advance.
>> Deval Shah
>> <libbsd-init01-test.log>_______________________________________________
>> devel mailing list
>> devel at rtems.org
>> http://lists.rtems.org/mailman/listinfo/devel
> --
> Deval Shah
> Graduate Student,
> B.E. (Hons.) Electrical and Electronics Engineering
> BITS Pilani Hyderabad Campus <http://www.bits-pilani.ac.in/hyderabad/>
> Github Profile <https://github.com/deval-maker>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/devel/attachments/20160712/9203e54e/attachment-0002.html>

More information about the devel mailing list