Require help with running Xilinx Zynq Qemu BSP

Jan Sommer soja-lists at
Tue May 10 10:32:09 UTC 2016

Am 2016-05-10 11:22, schrieb vivek kukreja:
> Hello all,
> I have compiled the RTEMS 4.12 to generate BSP for Xilinx Zynq Qemu.
> However, I am unable to find any documents on how to run the BSP.
> I tried using this document
> but this does not mention the steps for Xilinx Zynq, and also some of 
> the
> links in the document are dead.
> I haven't used Qemu, and will appreciate if someone can point me to the
> right document or give me tips to get this running.

I built a recent mainline qemu and could run an application with the 
following command

qemu-system-arm  -no-reboot \
                  -serial null -serial mon:stdio \
                  -net none -nographic \
                  -M xilinx-zynq-a9 \
                  -m 256M \
                  -kernel ticker/ticker.exe

However this only works for the xilinx_zynq_a9_qemu bsp. It might be 
possible to run applications for the zedboard bsp on qemu as well with 
the right device tree configuration, but I haven't tried that yet.

Best regards,


> Regards,
> Vivek
> _______________________________________________
> devel mailing list
> devel at

More information about the devel mailing list