Require help with running Xilinx Zynq Qemu BSP

vivek kukreja vivekkukreja5 at
Tue May 10 16:57:49 UTC 2016


Sorry for not framing the question properly.

I know how to run an application on the baremetal, with the command you
have mentioned. But I want to know how to run a complete RTEMS boot image,
along with OS components on the emulator.

In the document that I have given a link above, the steps for running a
boot image for i386 have been mentioned. Is the similar possible for the
Xilinx Zynq too?

On Tue, May 10, 2016 at 4:02 PM, Jan Sommer <soja-lists at>

> Am 2016-05-10 11:22, schrieb vivek kukreja:
>> Hello all,
>> I have compiled the RTEMS 4.12 to generate BSP for Xilinx Zynq Qemu.
>> However, I am unable to find any documents on how to run the BSP.
>> I tried using this document
>> but this does not mention the steps for Xilinx Zynq, and also some of the
>> links in the document are dead.
>> I haven't used Qemu, and will appreciate if someone can point me to the
>> right document or give me tips to get this running.
> I built a recent mainline qemu and could run an application with the
> following command
> qemu-system-arm  -no-reboot \
>                  -serial null -serial mon:stdio \
>                  -net none -nographic \
>                  -M xilinx-zynq-a9 \
>                  -m 256M \
>                  -kernel ticker/ticker.exe
> However this only works for the xilinx_zynq_a9_qemu bsp. It might be
> possible to run applications for the zedboard bsp on qemu as well with the
> right device tree configuration, but I haven't tried that yet.
> Best regards,
>    Jan
> Regards,
>> Vivek
>> _______________________________________________
>> devel mailing list
>> devel at
> _______________________________________________
> devel mailing list
> devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the devel mailing list