error while running rtems-test with coverage

Vijay Kumar Banerjee vijaykumar9597 at gmail.com
Sun Apr 15 05:46:30 UTC 2018


On 15 April 2018 at 01:45, Cillian O'Donnell <cpodonnell8 at gmail.com> wrote:

> Switch one of these lines out in qemu.cfg.
>
> #%define qemu_opts_base -no-reboot -monitor none -serial stdio -nographic
> #%define qemu_opts_base -no-reboot -serial null -serial mon:stdio
> -nographic
> %define qemu_opts_base -no-reboot -monitor null -serial stdio -nographic
>
> Just comment out the one that's being used and uncomment one of the
> others. It should cause a complaint when the tests are run and the qemu cmd
> should show up in the log so we can take a look at it.
>


error: qemu.cfg:71: execute failed: qemu-system-sparc -no-reboot -monitor
null -serial stdio -nographic -no-reboot -monitor null -serial stdio
-nographic -M leon3_generic -kernel
/home/lunatic/development/rtems/kernel/leon3/sparc-rtems5/c/leon3/testsuites/samples/unlimited/unlimited.exe:
exit-code:1

run: qemu-system-sparc -no-reboot -monitor null -serial stdio -nographic
-no-reboot -mo    nitor null -serial stdio -nographic -M leon3_generic
-kernel /home/lunatic/development/rtem
s/kernel/leon3/sparc-rtems5/c/leon3/testsuites/samples/unlimited/unlimited.exe
-exec-trace
 /home/lunatic/development/rtems/kernel/leon3/sparc-rtems5/c/leon3/testsuites/samples/unlimi
  ted/unlimited.exe.cov





>
> On 14 April 2018 at 20:37, Vijay Kumar Banerjee <vijaykumar9597 at gmail.com>
> wrote:
>
>>
>>
>> -- vijay
>>
>> On 15 April 2018 at 00:50, Vijay Kumar Banerjee <vijaykumar9597 at gmail.com
>> > wrote:
>>
>>>
>>>
>>>
>>> On 14 April 2018 at 16:42, Cillian O'Donnell <cpodonnell8 at gmail.com>
>>> wrote:
>>>
>>>>
>>>>
>>>> On 14 April 2018 at 07:11, Chris Johns <chrisj at rtems.org> wrote:
>>>>
>>>>> On 14/4/18 8:02 am, Vijay Kumar Banerjee wrote:
>>>>>
>>>>>> Getting this error now seems like something is missing.
>>>>>>
>>>>>> ........
>>>>>>
>>>>>> RTEMS Testing - Tester, 5 (b2ba08b0da42 modified)
>>>>>> Coverage environment prepared
>>>>>> Traceback (most recent call last):
>>>>>>    File "/home/lunatic/development/rtems/test/rtems-tools/tester/rtems-test",
>>>>>> line 40, in <module>
>>>>>>      rt.test.run()
>>>>>>    File "/home/lunatic/development/rtems/test/rtems-tools/tester/rt/test.py",
>>>>>> line 353, in run
>>>>>>      tst.reraise()
>>>>>>    File "/home/lunatic/development/rtems/test/rtems-tools/tester/rt/test.py",
>>>>>> line 160, in reraise
>>>>>>      _test_reraise(*self.result)
>>>>>> NameError: global name '_test_reraise' is not defined
>>>>>>
>>>>>>
>>>>> The reraise logic was moved to the rtemstoolkit last year:
>>>>>
>>>>> https://git.rtems.org/rtems-tools/commit/?id=fa81491764861e6
>>>>> 3785a3faa241c488469087209
>>>>>
>>>>> It had some issues that have been fixed and it is being reused else
>>>>> where in the tester.
>>>>>
>>>>>
>>>>>> -- vijay
>>>>>>
>>>>>> On 13 April 2018 at 23:57, Vijay Kumar Banerjee <
>>>>>> vijaykumar9597 at gmail.com <mailto:vijaykumar9597 at gmail.com>> wrote:
>>>>>>
>>>>>>
>>>>>>
>>>>>>     On 13 April 2018 at 23:51, Cillian O'Donnell <
>>>>>> cpodonnell8 at gmail.com
>>>>>>     <mailto:cpodonnell8 at gmail.com>> wrote:
>>>>>>
>>>>>>         Hmmm it's not there. Even so I can almost guarantee you, the
>>>>>>         reason it's not running is that coverage_supported variable is
>>>>>>         not being found as true in qemu.cfg and so the the command to
>>>>>>         generated the trace files isn't run and there's no .cov files
>>>>>> in
>>>>>>         the end. So that's what you'll have to dig into.
>>>>>>
>>>>>>     Okay , I'll set it to global then.
>>>>>>
>>>>>>
>>>>> Changes need to be on the latest version of master before I will
>>>>> review them. The failure above indicate the code you have is not up to date.
>>>>>
>>>>
>>>> Yes that was the plan. Just to check Vijay your starting point was
>>>> using the ini-update branch from here?
>>>>
>>>> https://github.com/cillianodonnell/rtems-tools/tree/ini-update
>>>>
>>>> That branch is current rtems-tools master that I started to add things
>>>> back in. The only reraise in there is the one improrted from rtemstoolkit.
>>>>
>>>
>>> yes this is the branch I'm using , I checked the reraise error , not
>>> sure how it showed up buit I called it from the reraise module , and it
>>> got fixed . now I'm stuck here
>>>
>>> error: config error: qemu.cfg:36: No 'target' defined
>>>
>>
>> okay , fixed that .
>> still getting the warnings of the unable to read .cov
>>
>>>
>>> are we supposed to set the bsp to global as well ?
>>>
>>>
>>>>> The change you have made is generating an exception in the tester
>>>>> thread. If you want to continue down this path you will need to fix what
>>>>> ever you have added.
>>>>>
>>>>> The tests are run as threads separate from the main thread so the
>>>>> exception is caught and re-raised in the main thread letting you know. This
>>>>> is broken in the old code base you are using.
>>>>>
>>>>> Why not investigate the reason as indicated and sort if out what the
>>>>> new format configuration file needs?
>>>>>
>>>>> Chris
>>>>>
>>>>
>>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/devel/attachments/20180415/d7494996/attachment.html>


More information about the devel mailing list