GSoC Project | Basic Support for Trace Compass
Sebastian Huber
sebastian.huber at embedded-brains.de
Fri Aug 9 13:17:21 UTC 2019
On 09/08/2019 15:06, Ravindra Kumar Meena wrote:
> rtems-main.c cleanup:
> https://github.com/rmeena840/rtems-tools/commit/61d5dc45e43f0998ad9305d565926090215a5bdc
>
> Switch_event per CPU added:
> https://github.com/rmeena840/rtems-tools/commit/8ffe8bd2adea27772a9ab0e578539dd99fa0174b
>
> Have a look.
Ok, good. Please always check if the babeltrace and Trace Compass give
the right results after the changes.
If you use cctx->switch_event[ item->cpu ] and similar a couple of times
in a function, then please assign it to a local pointer and use it, e.g.
switch_event *se = &cctx->switch_event[ item->cpu ];
Please check all structure names and make the similar to the names used
in the metadata, e.g. swich_event -> event_sched_switch;
Please check the style of the if again, it should be:
if ( condition ) {
...
} else {
...
}
Check the white space and position of the { }.
When you have a function like get_api_of_id() you return the api, so the
variable should be named "api":
size_t api_id = get_api_of_id( cctx->thread_id_name[ item->cpu
].thread_id );
size_t api = get_api_of_id( cctx->thread_id_name[ item->cpu
].thread_id );
Declare all variables at the top of the function, e.g.
size_t api;
...
api = get_api_of_id( cctx->thread_id_name[ item->cpu ].thread_id );
--
Sebastian Huber, embedded brains GmbH
Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone : +49 89 189 47 41-16
Fax : +49 89 189 47 41-09
E-Mail : sebastian.huber at embedded-brains.de
PGP : Public key available on request.
Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
More information about the devel
mailing list