[GSoC 2020]: Weekly thread update

Chris Johns chrisj at rtems.org
Wed Jul 15 00:03:00 UTC 2020

On 15/7/20 4:30 am, Mritunjay Sharma wrote:
> Hello everyone,
> Pardon my mistake for that long thread. From now on the daily updates will be
> given on a thread that will end every week. 

Thank you :)

> 1) I studied about https://github.com/RTEMS/rtems-libbsd
> 2) Tried to fix the error that I reported yesterday: 
> ```

Why cut the compile command line used to build this file out of the message? The
compiler command is important because it lets us see what paths are being used
and I think there may be a problem with them.

> ../posix/rtems_init.c:38:10: fatal error: rtems/bsd/bsd.h: No such file or directory
>  #include <rtems/bsd/bsd.h>
>           ^~~~~~~~~~~~~~~~~

I cannot duplicate this because I am not sure what the sequence of commands are
you used to get to here. I am sorry if I missed it in a previous post.

The error indicates a set up issue. It normally means the networking software
(rtems-libbsd) has not been installed into a prefix path EPICS looks in.

> compilation terminated.
> make[4]: ***
> [/home/mritunjay/development/EPICS/epics-playground/configure/RULES_BUILD:235:
> rtems_init.o] Error 1
> make[4]: Leaving directory
> '/home/mritunjay/development/EPICS/epics-playground/modules/libcom/RTEMS/O.RTEMS-pc386'
> make[3]: ***
> [/home/mritunjay/development/EPICS/epics-playground/configure/RULES_ARCHS:58:
> install.RTEMS-pc386] Error 2
> make[3]: Leaving directory
> '/home/mritunjay/development/EPICS/epics-playground/modules/libcom/RTEMS'
> make[2]: ***
> [/home/mritunjay/development/EPICS/epics-playground/configure/RULES_DIRS:84:
> RTEMS.install] Error 2
> make[2]: Leaving directory
> '/home/mritunjay/development/EPICS/epics-playground/modules/libcom'
> make[1]: *** [../configure/RULES_DIRS:84: libcom.install] Error 2
> make[1]: Leaving directory
> '/home/mritunjay/development/EPICS/epics-playground/modules'
> make: *** [configure/RULES_DIRS:84: modules.install] Error 2
> ```
> I am still not successful even though I tried to search for it. 

I doubt there will be anything to search for. You are solving the problem and
creating the first info to be searched. We need to debug the problem.

> On the advice of Heinz, I have already built EPICS 7 with RTEMS4.10
> by hand and am on the verge of doing the same for EPICS7 with RTEMS5 
> for pc-386. 

I am sorry I do not understand what "on the verge of doing the same" means.

> However, I will like to request all my mentors to help me set the goals
> for this week and where should I begin next?

Could you please update your blog with the exact command sequences you are using
to build EPICS7 for RTEMS 4.10 and EPICS7 for RTEMS 5 for a PC?

Have you run EPIRC7 for 4.10 in qemu? If so did the network come up and work?

Have you run the rtems-libbsd test executables in qemu?


More information about the devel mailing list