How to run the full RTEMS testsuite

Ida Delphine idadelm at
Sat Apr 10 19:44:48 UTC 2021

For some reason I get this:
rtems-test: command not found
I've used this command a few times and it worked. I don't know what I
am doing wrong now...
Any idea what I am doing wrong?

On Sat, Apr 10, 2021 at 12:43 PM Eshan Dhawan <eshandhawan51 at>

> Hi
> You can use rtems-test to run tests in a directory
> Eg :
> rtems-test --rtems-bsp=erc32-run --rtems-tools=$HOME/development/rtems/5 ~/development/rtems/kernel/erc32/sparc-rtems5/c/erc32/testsuites/samples
> Thanks
> Eshan
> On 10-Apr-2021, at 5:01 PM, Ida Delphine <idadelm at> wrote:
> Hello everyone,
> I'm looking forward to work on automatic style checking and code
> formatting for RTEMS as my GSoC project and will need to test that style
> changes do not cause any implementation bugs. I will carryout this test by
> running the full RTEMS testsuite. I've tried looking in the RTEMS
> documentation for a detailed step by step guide on how to do this but I
> can't find anything helpful. Can someone please guide me on how to achieve
> this?
> Cheers,
> Ida.
> _______________________________________________
> devel mailing list
> devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the devel mailing list