qemu-linaro and linaro-image-tools is olde

Christian MAUDERER christian.mauderer at embedded-brains.de
Thu Apr 4 05:19:18 UTC 2024

Hello Ashish,

On 2024-04-03 05:07, ashish ashish wrote:
> Hello all,
> I am trying to emulate beagle black board
> and support for beagle board on qemu in past can be achieved by qemu-linaro
> but from last 10 years there is not activity on the community of 
> qemu-linaro and it is
> use many depreciated packages and hard to got it work anyone tried it or 
> using it.

If the upstream qemu didn't pick up the changes and if no one else took 
over maintenance, you are most likely out of luck. Your best chance to 
get that running (with a reasonable amount of work) would most likely be 
a VM with an old Linux distribution.

> and ppa:linaro-maintainers/tools is down(404 when adding it to apt). 
> tried compiling  from sources but it uses python2 and many depreciated 
> python2 packages

If the sources are not there anymore, that's even more difficult. You 
will have to search whether you find them in some archives.

If it is not absolutely crucial for you to get the Qemu for BBB running, 
I would suggest against trying it.

Did you note any RTEMS documentation, scripts or source builder recipes, 
that don't work and that maybe should be updated or removed?

Best regards


More information about the devel mailing list