Debian-host build error...
esutter at alcatel-lucent.com
Tue Jun 30 15:43:00 UTC 2009
Ralf Corsepius wrote:
> Ed Sutter wrote:
>> Ralf Corsepius wrote:
>>> Ed Sutter wrote:
>>>> Well, the story continues...
>>>> I managed to update my machine from etch to lenny (debain releases),
>>>> and that allowed me to successfully execute the tools (almost)...
>>>> Now the command "bfin-rtems4.10-gcc --help" actually prints the help
>>>> message, I don't see the message...
>>>> bfin-rtems4.10-gcc: /lib/tls/i686/cmov/libc.so.6:
>>>> version `GLIBC_2.4' not found (required by bfin-rtems4.10-gcc)
>>>> any more.
>>>> So, with that, I took a blazing step forward and actually tried to
>>>> compile a file with "bfin-rtems4.10-gcc main.c", and now I get this...
>>>> version `GLIBC_2.8' not found (required by
>>>> Somebody shoot me...
>>> It's quite simple: You are facing another incarnation of the same
>>> issue again. The rpms you are unpackaging and trying to use on Debian
>>> are incompatible to those libraries you have installed on Debian.
>> Yep, I realize that, I was just posting to the list for reference in case
>> someone else goes this route. Note, I'm not complaining about the tools,
>> just trying to share the info.
>>> Unfortunately, you are still providing too little details, to be able
>>> to help.
>>> * Which glibc compatiblity modes does it supply?
>>> nm -sD /lib/libc.so.6 | grep GLIBC
>> els:nm -sD /lib/libc.so.6 | grep GLIBC
>> 00000000 A GLIBC_2.0
>> 00000000 A GLIBC_2.1
>> 00000000 A GLIBC_2.1.1
>> 00000000 A GLIBC_2.1.2
>> 00000000 A GLIBC_2.1.3
>> 00000000 A GLIBC_2.2
>> 00000000 A GLIBC_2.2.1
>> 00000000 A GLIBC_2.2.2
>> 00000000 A GLIBC_2.2.3
>> 00000000 A GLIBC_2.2.4
>> 00000000 A GLIBC_2.2.6
>> 00000000 A GLIBC_2.3
>> 00000000 A GLIBC_2.3.2
>> 00000000 A GLIBC_2.3.3
>> 00000000 A GLIBC_2.3.4
>> 00000000 A GLIBC_2.4
>> 00000000 A GLIBC_2.5
>> 00000000 A GLIBC_2.6
>> 00000000 A GLIBC_2.7
>> 00000000 A GLIBC_PRIVATE
> OK, this is too old for any Fedora. All current Fedoras are at Glibc-2.8
> or above.
>>> * Which distro's rpms are you trying to use?
>> I'm running with Debian (lenny/stable).
>> Following is the list of rpms I ran through alien and installed...
> You could try to "alien"ize the CentOS5 rpms.
> They only require glibc-2.4 and therefore likely are sufficiently
> compatible to your Debian.
Just to keep the email in sync...
Prior to getting this message, I restarted with redhat/el5, and as reported,
it looks good!
More information about the users