Missing Dependencies on CentOS Image

Joel Sherrill joel.sherrill at OARcorp.com
Tue Aug 14 13:18:53 UTC 2012

On 08/02/2012 10:59 PM, Kevin Polulak wrote:
> While using the RTEMS CentOS image 
> <http://sourceforge.net/projects/rtems-vms/> to setup a new 
> development environment on my laptop, I ran into the missing libmpc 
> dependency error again. I've encountered this error before and it 
> occurs while trying to install some of the *-rtems4.11-gcc packages. 
> On my desktop machine, I had to try and find a copy of libmpc and 
> compile it from source. If I remember correctly, I think I even had to 
> modify a few environment variables as well (it might've been 
> $LD_LIBRARY_PATH). Now, on my laptop, I used the --skip-broken switch 
> to yum instead and just hoped it doesn't cause any problems in the 
> future. This kinda confuses me since the MPC library was included 
> starting with GCC 4.5 and the *-rtems4.11-gcc packages are 4.6.
As I mentioned in a private email, recent updates to the RTEMS GCC binaries
imposed the requirement of libmpc.so.2 which is NOT available in the CentOS
Repositories installed by default.

Install the EPEL Repository (http://fedoraproject.org/wiki/EPEL) and 
when you
do a yum upgrade, it will pick up the libmpc.so.2 RPM dependency and
magically load it for you.

FWIW there was no formal announcement about this on the mailing list.
This dependency was added after I built the last CentOS virtual machine.

> What I'm getting at though is, shouldn't stuff like this be included 
> with the image from the start? That is, shouldn't the image already 
> have things like libmpc installed? After all, the description for the 
> image reads "provides preconfigured Virtual Machines which include an 
> RTEMS Development Environment" yet there are several things you still 
> need to install.
Everything was OK in February when that VM was built. The addition of the
libmpc.so.2 dependency was after that.
> For that matter, is there anything wrong with just having /all/ the 
> RTEMS build tools installed? Sure that's a lot of packages but after 
> adding up the size of every package containing the word "rtems", it's 
> only ~1.04 GB. Other than an old copy of the RTEMS source code and 
> having yum configured to search the RTEMS repos, there's really not 
> much that makes this an "RTEMS development environment". Unless I've 
> misunderstood the purpose of the CentOS image, shouldn't users be able 
> to just boot up the image and be able to build from source right away 
> for /any/ BSP?
It wouldn't have solved this problem. You still wouldn't have been able 
to update because
libmpc.so.2 was needed by the newer gcc rpms.

Also it is easy to add all the tools but not many people will want them. 
The VMs are intended
to be useful to get started with. Most people probably will never want 
more than 1-3 targets.
We have always recommended some combination of SPARC, x86, PowerPC, and 
MIPS for

+ SPARC/sis - simulator in gdb, easy to use, matches ERC32
+ pc386 - on qemu, matches PC, has networking and graphics
+ powerpc/psim - standard easy to use PowerPC, in gdb
+ mips/jm43904 - easy to use gdb simulator, no valid memory < 0x88000000 
so faults on NULLs

Those four cover most testing situations which don't require specific 
target or HW.

> As a side note, the bootstrap script fails until a newer version of 
> autotools in installed. Perhaps it's time the CentOS image got an 
> update overhaul?
I am doing that. But if you added EPEL and did a yum upgrade, it would 
just work. That's
all I did. :)
> -- 
> - Kevin Polulak (soh_cah_toa)
> - http://cybercrud.net

Joel Sherrill, Ph.D.             Director of Research&   Development
joel.sherrill at OARcorp.com        On-Line Applications Research
Ask me about RTEMS: a free RTOS  Huntsville AL 35805
     Support Available             (256) 722-9985

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rtems.org/pipermail/devel/attachments/20120814/a575c92b/attachment.html>

More information about the devel mailing list