Decision which RTEMS to use-new project i386EX-Tool Chain?

Ralf Corsepius corsepiu at
Thu Jun 22 16:41:48 UTC 2000

John Jeffers wrote:
> A while back I had a computer that built RTEMS 4.0.0 using standard
> installs wayyyyy.... back in RH 4.2 days.  (Feels like Rocky and Bulwinkle
> now.)
> On a new RTEMS project using a 386ex I am struggling to understand on a Red
> Hat 6.2 install (Yes I like it!) Should I.
> 1) Try and recreate the 4.0.0 build tools. (Seem's like a task today!)
I would not recommend to do so, but you might have to do so, because
the i386ex is special (cf. below)
> 2) Use 4.5b3 using prebuilt rpms per Joel (6 June 2000 response to diff's
> question)
Generally speaking: yes. 

But there are a few exceptions, AFAIK (I am not using any of these
targets, so people actually using these might know better than me):
* gcc-2.95.2 is broken for the hppa-1.1 in general.

* The i386ex-BSP applies soft-floats. Currently, there doesn't seem
to exist a patch (At least none known to me) to merge
i386-soft-float support into gcc-2.95.x. AFAIK, there are patches
against older gcc-versions, but nobody seems to have merged them
into gcc-2.95.2, yet.
> 3) Use 4.0.0 using prebuilt rpms (haven't a clue if this is "supposed" to work)
Well, it is not "supposed" (== untested) to work, but there is very
high chance that it will.

Anyway, if starting a new project I would recommend to start with
the latest beta. If already having something working based on 4.0.0
(e.g. a BSP), you would have to port it to 4.5 first (esp. Makefiles
and configuration). This isn't actually difficult, but based on your
experience with auto*-tools and RTEMS, your mileage may vary
(effort: 0.5h - 1week, realistic: 1-2 days + runtime testing).

> 4) Or should I go back to RH5.2 and use the rpms?
I don't know any reason for doing so. 

Joel uses a RH-5.2 box for building the rpms to be glibc-2.0.x and
rpm-2.x compatible. The primary reason for him doing so is for not
getting swamped into a glibc2 versioning and compatibility debacle.
However these binaries should run on any contemporary (glibc version
>= 2.1) linux.

If you'd like to get optimized binaries using the latest and
greatest glibc2 and rpms your host-OS comes with, simply rebuild the
rpms :)


Ralf Corsepius 
Forschungsinstitut fuer Anwendungsorientierte Wissensverarbeitung
Helmholtzstr. 16, 89081 Ulm, Germany     Tel: +49/731/501-8690
mailto:corsepiu at           FAX: +49/731/501-999

More information about the users mailing list